Mac OS X® 10.6 (Snow Leopard) is an older OS X version that is no longer compatible with modern software. To use our software and desktop apps, you will need to upgrade your operating system to Mac OS X 10.7 (Lion) or newer.

Need more information about OS X upgrades? Visit the Apple® Support website.